Web-Access-Log

Web Access Log

Maintaining the users Internet Access Log is One of the mandatory requirement by Law Enforcement / Government.

neuCRM supports receiving Log from NAS, and save it as compresed log file (inorder to save storage space), and you are allowed to search in the Log file by using IP address/MAC Addr/ PPPoE username.



Image

Access Log can be viwed in neuCRM menu Admin → Radius → Access Log


Mikrotik NAS configuration for Web Access Log

  1. Configure the NAS as below for Sending access log to neuCRM server
  2. NAS must send its log to neuCRM on UDP Port: 514.
  3. neuCRM is receiving log records in UDP Port: 514.
  4. neuCRM will save the received log entry in a file, NAS wise.
  5. At the end of the day, neuCRM compressing this log file inorder to save disk space
  6. You can seach Log entries through web front as shown in above picture
  7. The Sample configuration for Enabling in Mikrotik Router OS NAS is as below:


  8. Image


    Router OS Command for Enabling NAS to send Web access log to neuCRM:
    /ip firewall filter
    add action=log chain=forward connection-state=new src-address=0.0.0.0/0
    
    /system logging add name=Log remote=172.20.20.1 remote-port=514 target=remote
    
    /system logging add action=Log topics=firewall
    

    Here 172.20.20.1 is neuCRM server's IP address given for example. Replace this IP address with yours.

  9. Periodically Download the Log files through FTP from neuCRM server and keep it in safer place. After Download, please delete those files in neuCRM Virtual Machine, to free some space. Because Log files are consuming huge space in your Virtual Machine's Virtual Harddisk file.
  10. FTP Access is permitted to serveradmin Login Only.

© 2018 neuCRM. All rights reserved.