Configuration : NonPayment

Non Payment Configurations

neuCRM has two diffrent status for Non Payment Cases

  1. NP - Non Payment Status. Customer is modified from Active to NP status if he not paid the balance dues before due date. In Non Payment (NP) status customer still getting Internet access, but in reduced speed. This reduced speed Configuration is specified as below. This NP Status is allowed to this customer upto certain period. This period is called Grace Period. After this grace period expires, then status changed to NPD (Non Payment Disconnection).
  2. NPD - Non Payment Disconnection Status. In this status customer is blocked to access Internet.

neuCRM handle Non Payment in diffrent way for Prepaid & Postpaid customers.



Essential Configuration for NPD customer in NAS:

Another Important thing is that you need to create a new IP Pool called: blocked_pool in NAS. This name should be same. Bacause neuCRM send instruction to NAS use the IP Pool named blocked_pool for the blocked customers.


If your NAS is Mikrotik Router OS, then IP Pool creation Command is:
 /ip pool
add name=blocked_pool ranges=192.168.238.2-192.168.238.254
.

You can specify IP Range as you wish. There is no necessity to use the above same 192.168.238.x IP Range.

And this blocked_pool range IPs are to be blocked in Firewall to access the Internet


Mikrotik Router OS Command for Firewall Block rule:
 /ip firewall
add action=drop chain=input comment="Blocled IP Pool" src-address=192.168.238.0/24

This Configuration is mandatory in you NAS. Other wise Unpaid customers will not blocked.



Postpaid Accounts

Postpaid customers are moved to NP status, when they non paid dues before due date. Those customers will be remain in NP status upto NP Grace Period. If they not paid up to NP Grace Period, then those users will be moved to NPD Status.



Prepaid Accounts

Prepaid customer are directly moved to NPD Status when they Not Paid for forth comming period (next Renewal period) before expiring of the Validity. No Grace Period is allowed to Prepaid Customers. And Prepaid customer account is Renwed only if it has Sufficient Balance Amount on his Account. For example already paid excessively $20, and he is having negative Amount on his Account, ie. -$20. Lets assume this customer is in $100 plan. While expiring his Validity, system calculates the required balance amount for Auto Renewal. Since this customer is in $100 Bill plan, and he must have minimum -$100 on his account for Auto renewal.



Credit Limits

According to the neuCRM Prepaid customers Validity will be auto Renewed only if he has sufficient balance on his account. Similarly users will be Disconnected when not paid dues for the Postpaid services.

But in some cases you would like to allow some customers without Disconnection up to certain limit. For that scenario use Credit Limit Settings.

    Credit Limit has two scopes:
  1. Global Credit Limit,
  2. Individual User's Credit Limit.

Golobal Credit Limits are Applicable to System wide. This can be configured through : Admin → Settings → Config menu. This value will be used only when no User's specific credit limit was not configured.

If User's specific credit limit is Configured, Global Credit Limit is ignored. User's Credit Limit can be configured at in : Service → Settings menu.



Configurations

Configuration name begines with npd_ refers to Non Payment Disconnection(NPD) status

Configuration name begines with np_ refers to Non Payment(NP) Status

Configuration Name Possible Values Applicable to Description
np_enable Y,N ISP, Reseller This Enable/Disable NP Activity
np_period_dl_bandwidth_kbps Integer Value ISP, Reseller Set Download Bandwidth rate during NP Grace Period
np_period_ul_bandwidth_kbps Integer Value ISP, Reseller Set Upload Bandwidth rate during NP Grace Period
npd_enable Y,N ISP, Reseller This Enable/Disable NPD Function
npd_grace_days Integer Value ISP, Reseller NP Grace Period. ie. No. of Days Between NP to NPD.
npd_threshold_amt Integer Value ISP, Reseller Do NPD only when, Balance due exceeds this threshold amount


© 2018 neuCRM. All rights reserved.