NAS-Config

Officially neuCRM is tested and supporting Mikrotik Router OS as NAS

It doesn't means that it will not support other NAS. The Generic RADIUS coding inside th neuCRM must works with most of the NAS products.



Mikrotik NAS configuration for RADIUS Authentication.

Image


  1. Configure your Mikrotik Router as shown above.
  2. The RADIUS ip address 172.20.20.3 is used here for demo purpose only. Use your neuCRM Server IP address in place of this.
  3. RADIUS incomming port must be 3799 on NAS. neuCRM RADIUS server using this port to communicate with NAS.
  4. Create a IP-Pool if your planing to provide Dynamic IP address to your clients
  5. Create PPPoE Service on the required Ethernet Interface
  6. Create & assign a PPPoE profile to the PPPoE Service.
  7. The below Diagram shows you a typical Mikrotik Router Configuration, for more detail please refer Mikrotik online Documentation
  8. Image
  9. Another Important thing is that you need to create a new IP Pool called: blocked_pool. This name should be same. Bacause neuCRM send instruction to NAS use the IP Pool named blocked_pool for the blocked customers.

  10. Router OS Command:
     /ip pool
    add name=blocked_pool ranges=192.168.238.2-192.168.238.254
    
    .
  11. You can specify IP Range as you wish. There is no necessity to use the above same 192.168.238.x IP Range.
  12. And this blocked_pool range IPS are to be blocked to access Internet in Firewall

  13. Router OS Command:
     /ip firewall
    add action=drop chain=input comment="Blocled IP Pool" src-address=192.168.238.0/24
    
  14. Now your customer should able to connect through PPPoE
  15. NAS to neuCRM using TCP Port: 1812 for Authentication, and TCP Port:1813 for Accounting Updates.
  16. NAS has to send its log to neuCRM on UDP Port: 514 for Updating webaccess log.

© 2018 neuCRM. All rights reserved.